VMware vRealize® Automation™ and Storage Policy Based Management Framework Integration

INSTALLATION AND CONFIGURATION GUIDE
V2.1.1 FEBRUARY 2017
Deliverables

• This documentation
• VMware vRealize® Orchestrator™ vRA SPBM Integration plug-in

Terminology

• vRealize Automation (previously vCloud Automation Center)
• vRealize Orchestrator (previously vCloud Orchestrator)

Prerequisites

• Install vRealize Automation 7.1.0.
• Install IaaS Server 7.1.0.
• Install vRealize Orchestrator 7.1.0 if you are using a stand-alone vRealize Orchestrator server.
• Configure the vRealize Automation tenant.
• Have a vRealize Automation Advanced license.
Install the vRealize Automation SPBM Integration vRealize Orchestrator Plug-in

If you already have the vRealize Automation SPBM package version 1.0.0 or 2.0.0 installed, you must uninstall the package in the vRealize Orchestrator client before installing the vRealize Automation SPBM Integration vRealize Orchestrator plug-in.

1. In the vRealize Automation appliance, click vRealize Orchestrator Control Center.

The vRealize Orchestrator Configuration service is not started by default in the vRealize Automation appliance. Follow the vRealize Automation documentation to enable it if the vRealize Orchestrator configuration is not available.
2. Under **Manage Plug-ins**, **Browse** to vra-spbm-integration-2.1.1.vmoapp, and click **Install**.

3. Under **Startup Options**, click **Restart** to reboot the vRealize Orchestrator server service.

4. When the vRealize Orchestrator server service is available again, connect to the vRealize Orchestrator client.
Configure vRealize Orchestrator Inventory Objects

Configure the vRealize Orchestrator vRealize Automation host, IaaS host, and vCenter Server instance.

1. Connect to the vRealize Orchestrator client.
3. Run **Add a vRA host**, type a **Host Name** and **Host URL**, and click **Next**.

<table>
<thead>
<tr>
<th>Add a vCAC host</th>
<th>1 Host Properties</th>
<th>Properties to create a new host. The name is the host's unique identifier.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Host Name</td>
<td>sh-vcac182-096.eng.vmware.com</td>
</tr>
<tr>
<td></td>
<td>Host URL</td>
<td><a href="https://sh-vcac182-096.eng.vmware.com">https://sh-vcac182-096.eng.vmware.com</a></td>
</tr>
<tr>
<td></td>
<td>Automatically install SSL certificates</td>
<td>Yes (✔) No</td>
</tr>
<tr>
<td></td>
<td>Connection timeout (seconds)</td>
<td>30.0</td>
</tr>
<tr>
<td></td>
<td>Operation timeout (seconds)</td>
<td>60.0</td>
</tr>
</tbody>
</table>
4. Select **Shared Session** from the **Session mode** drop-down menu, type the credentials, and click **Submit**.

![Image of vRealize Automation interface](image)

<table>
<thead>
<tr>
<th>1 Add a vCAC host</th>
<th>Session mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>1a Host Properties</td>
<td>Shared Session</td>
</tr>
<tr>
<td>2 Host Authentication</td>
<td>Tenant</td>
</tr>
<tr>
<td>2a User Credentials</td>
<td>Authentication username</td>
</tr>
<tr>
<td></td>
<td><a href="mailto:kitz@vsphere.local">kitz@vsphere.local</a></td>
</tr>
<tr>
<td></td>
<td>Authentication password</td>
</tr>
<tr>
<td></td>
<td>**********</td>
</tr>
</tbody>
</table>

![Image of vRealize Automation interface](image)
5. If there is no default host configured, navigate to **Workflows**, and expand workflow folder **Library -> vRealize Automation -> Infrastructure Administration -> Configuration**.

6. Run **Add an IaaS host**, type the **Name** and **Host URL**, and click **Next**.
7. Select **Yes** for **Default connection settings**, and click **Next**.
8. Select **SSO** from the **Host authentication type** drop-down menu, type the credentials, and click **Submit**.
9. Navigate to **Library -> vCenter -> Configuration** and click **Add a vCenter Server instance**.
10. Type the IP address of host name, HTTPS port, and SDK location for the vCenter Server instance that is used for the corresponding endpoint in vRealize Automation, and click Next.
11. Type the user name and password that vRealize Orchestrator will use to connect to vCenter Server, and click Submit.

After the workflow runs successfully, the vCenter Server instance appears in the vRealize Orchestrator Inventory.
Enable the Set Storage Policy for Virtual Machine Provisioning

1. Connect to vRealize Automation as Tenant Admin.
2. Navigate to Administration > Property Definitions, and add property definitions “VMHomeStoragePolicy” and “VirtualMachine.DiskN.DiskStoragePolicy” (where N is the number of Disk, starting from 0) in the property definitions.
3. Enter the following information in the property definitions.
   a) Set the Data type to String.
   b) Set the Display advice to DropDownList.
   c) Choose External values and select getStoragePoliciesBasedOnEndpointName in com.vmware.library.spbm.
   d) Input endpointName and forVMHome. Set forVMHome as true for VMHomeStoragePolicy, and false for DiskStoragePolicy.

   **Note:** The value of endpointName is the name of vSphere Endpoint defined in Infrastructure.
4. Navigate to Design -> Blueprints, open the blueprint you want to enable the storage policy. Add property VMHomeStoragePolicy to your blueprint, set value to Datastore Default, and check Show in Request.

![VMware vRealize Automation and Storage Policy Based Management Framework Integration](image)

5. Optionally set DiskStoragePolicy to each volume’s property, set the value to Use VM Home Storage Policy, and check Show in Request to enable the feature of applying the storage policy to disks when provisioning a virtual machine.

![VMware vRealize Automation and Storage Policy Based Management Framework Integration](image)

6. Navigate to Infrastructure -> Endpoints -> Endpoints, and edit the endpoint being used for the blueprints for which you want to enable the storage policy.
   a) Add the property Extensibility.Lifecycle.Properties.VMPSMasterWorkflow32.MachineProvisioned and set the value to *.
   b) Add the property spbm_vc_username and set the value to your vCenter’s username.
   c) Add the Encrypted property spbm_vc_password and set the value to your vCenter’s password.
   d) Add the property spbm_vc_sslthumbprint and set the value to vCenter’s SSL thumbprint. You can follow the Obtain the SSL Certificate Thumbprint article to get vCenter’s SSL thumbprint.
7. Navigate to **Administration -> Events -> Subscriptions**, create a new workflow subscription.

8. In the **Event Topic**, choose **Machine provisioning**.

9. In the **Conditions**, select **run based on conditions**, and select all of the following.
   
   a) Add expression **Data > Lifecycle state > Lifecycle state name** Equals **VMPSMasterWorkflow32.MachineProvisioned**.
   
   b) Add expression **Data > Lifecycle state > State phase** Equals **PRE**.
   
   c) Add expression **Data > Blueprint name** Equals your blueprint name.

   This is just a sample. You can define the conditions based on your demand.
10. In the **Workflow**, go to **Orchestrator -> Library -> SPBM** and select **Set Storage Policy**.

11. On the **Details** tab, select **Blocking**.
12. Select **Finish** and **publish** this subscription.

The granted tenant user can request VM with VM Home, Disk0 and Disk1 policies applied.

vSphere Machine: CentOS

<table>
<thead>
<tr>
<th>General</th>
<th>Storage</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Instances</em>: 1</td>
<td><em>Memory (MB)</em>: 1024</td>
</tr>
<tr>
<td>CPUs: 1</td>
<td>Storage (GB): 8</td>
</tr>
<tr>
<td>VM Home Storage Policy: High Availability</td>
<td>Disk 0 Storage Policy: High Performance</td>
</tr>
<tr>
<td>Disk 1 Storage Policy: High Performance</td>
<td></td>
</tr>
</tbody>
</table>

After a few minutes, the virtual machine is created and the policies are applied.
Enable Change Storage Policy for Storage Migration

1. Connect to vRealize Automation as Tenant Admin.

2. If you are using stand-alone vRealize Orchestrator service, navigate to Administration > vRO Configuration > Server Configuration, and check Use an external Orchestrator server.

3. Type the vRealize Orchestrator information, and click Update.

4. Navigate to Design > Xaas > Resource Actions, and create a new resource action.

5. In Workflow, navigate to Orchestrator > Library > SPBM and select Change Storage Policy for Storage Migration.

7. In Details, optionally input the name of the action.
8. Click the **Forms** tab.
9. Type the **Policy Name** and choose **Drop-down** from the **Type** drop-down menu.
10. In **Values**, choose **External values** and select `getStoragePoliciesBasedOnVM` in `com.vmware.library.spbm`.

11. For **vCenterVM**, select **Field**, select **vcVM**, and click **Apply**.

12. For **IAASServer**, select **Field**, select **IAASServer**, and click **Apply**.
13. Edit IAASServer, navigate to Constraints > Value > Constant, select the IAAS entity and click Apply.

14. After you submit the action, publish it and add it to entitlement.

15. To set policy change as a tenant user, select the virtual machine, apply the Change Storage Policy Action. Choose the policy you want to apply as well as the option.
The policy is applied and disks are migrated to the VMware vSAN™ datastore.

Enable Change Storage Policy for Cross vCenter Migration

1. Connect to the vRealize Orchestrator client and add destination vCenter server to the vRO Inventory.
2. Connect to vRealize Automation as Tenant Admin.
3. Ensure the destination vCenter has the corresponding endpoint. The destination endpoint should have `spbm_vc_username`, `spbm_vc_password`, and `spbm_vc_sslthumbprint` custom properties configured.
4. Ensure the appropriate destination reservation and blueprint are configured.

5. If you are using stand-alone vRealize Orchestrator service, navigate to Administration > vRO Configuration > Server Configuration, select Use an external Orchestrator server, the the
vRealize Orchestrator information, and click **Update**.

7. In **Workflow**, go to **Orchestrator > Library > SPBM** and select **Change Storage Policy for Cross vCenter Migration**.
8. In **Input Resource**, select **IaaS VC VirtualMachine** for **Resource type**, and select **vcVM** for **Input Parameter**.

![New Resource Action](image)

9. On the **Details** tab, optionally type the name of the action.

![Change Storage Policy for Cross vCenter Migration - Edit Resource Action](image)

10. Click the **Forms** tab.
11. Edit **Storage Policy** and choose **Drop-down** in the **Type** drop-down menu.

12. In the **Values**, choose **External values**, and select `getStoragePoliciesBasedOnEndpoint` in `com.vmware.library.spbm`.
13. For `iaasHost`, click **Field**, select **IaaS**, and click **Apply**.

14. For `endpoint`, click **Field**, select **Destination Endpoint**, and click **Apply**.
15. Edit IaaSServer, navigate to Constraints > Value > Constant, select the IAAS entity, and click Apply.

16. Edit Destination Endpoint, navigate to Constraints > Value > Constant, select the destination endpoint entity, and click Apply. Set Read only as true to prevent the end user from editing it.
17. Edit Destination Reservation, navigate to Constraints > Value > Constant, select the destination reservation entity, and click Apply. Set Read only as true to prevent the end user from editing it.

18. Edit Destination Blueprint, navigate to Constraints > Value > Constant, select the destination blueprint entity, and click Apply. Set Read only as true to prevent the end user to edit it.

Note: You must choose the composite blueprint under the vRealize Automation inventory object.
you added in vRealize Orchestrator rather than the default vRealize Automation inventory object.

19. Edit **Destination Blueprint Component**, go to **Constraints > Value > Constant**, input the destination blueprint component id, and click **Apply**. Set **Read only** as **true** to prevent the end user from editing it.
20. To specify the datastore list for the destination datastore of the vm, edit **Destination Datastores**, navigate to **Constraints > Value > Constant**, select the datastores, and click **Apply**.

![Change Storage Policy for Cross vCenter Migration - Edit Resource Action](image)

21. To specify the network list for the destination standard switch of the vm, edit **Destination Networks**, navigate to **Constraints > Value > Constant**, select the networks, and click **Apply**.

**Note**: Destination Networks and Destination Distributed Virtual Portgroups will be used to set destination VM NICs based on source NIC’s network type. For example, if the VM has 3 NICs, the first one uses Standard Switch, and the others use Distributed Switch. You need to add one destination Standard Switch in Destination Networks, and add two destination Distributed Switches in Destination Distributed Virtual Portgroups. After migration, the VM will use inputted destination Standard Switch for the first NIC, and use inputted destination Distributed Switches for the second and third NIC.

![Change Storage Policy for Cross vCenter Migration - Edit Resource Action](image)
22. To specify the distributed virtual portgroup list for the destination distribute switch of the virtual machine, edit **Destination Distributed Virtual Portgroups**, navigate to **Constraints > Value > Constant**, select the distributed virtual portgroups, and click **Apply**.

![](image.png)

23. Edit **Identity User**, navigate to **Constraints > Value > Constant**, input the identity user for the migrated virtual machine, and click **Apply**.

![](image.png)

24. After submitting the action, publish it and add it to entitlement.

25. Change storage policy for cross vCenter migration as a tenant user. Select the virtual machine you want to migrate, click **Change Storage Policy for Cross vCenter Migration**, and choose the policy
you want to apply it to.

The virtual machine is migrated to the destination vCenter and the policies are applied.
In vRealize Automation, a new deployment is created with the migrated virtual machine.
About the Author and Contributors

Gary Chen and Chen Wei, solution architect (engineer) in the Storage and Availability, Product Enablement team wrote the original version of this paper. Catherine Xu, technical writer in the Product Enablement team, edited this paper to ensure that the contents conform to the VMware writing style.